Issue_0005 

Fuego wiki

Login or create account

Issue 0005

Summary
Use latest Jenkins version for Fuego
Owner
Tim
Reporter
AGL JTA
Status
closed
Priority
very high

Description [edit section]

The current fuego repository uses a snapshotted debian package, of Jenkins version 1.509.2.

However, Fuego should change to using latest Jenkins version. (2.7.1 is the latest LTS release)

There are numerous reasons this is important.

The AGL test team has already updated their version to a later Jenkins version. They want to update Jenkins as needed to get recent security fixes for the system.

In order to avoid having the AGL project stay forked from Fuego, we need to adopt the latest version.

Also, we should make sure we refactor the container build system to avoid using Jenkins and plugin snapshots anyway.

Notes [edit section]

There are some issues with upgrading:
  • making sure all snapshotted plugins work in the new system

What things have changed? [edit section]

Apparently some of the plugins don't work with Jenkins 2.7.1.
  • flot
  • plot?

I believe that the build_number or build_id is now different, and this causes problems for software dependent on these

  • FIXTHIS - investigate build_number build_id difference between Jenkins versions

backlink

Fuego Issues List

TBWiki engine 1.8.2 by Tim Bird